2017年9月26日(火) 01:47 JST


 掲示板目次 > CEAS掲示板 > 導入のヒント トピック新規登録 新しく書き込む
 CEAS-Sakaiのバージョンアップについて
 |  印刷用ページ
ty-matsu
 2011年10月12日 09:12 JST (参照数 1728回)  
掲示板 Junior
Junior

状態: オフライン
登録日: 2011年4月27日
投稿数: 15

お世話になります。

現在は、Linux(Cent OS 5)上でCEAS-Sakai 1.0.3を試験運用しております。

ところで、CEASについて3.0.11から3.0.12にバージョンアップしたいという
要望があり、CEAS-Sakaiだと1.0.4をインストールすることでCEASが3.0.12に
なると思います。

そこで質問なのですが、新規インストールではなく、このままデータを残して
バージョンアップすることは可能でしょうか。

可能な場合、その手順についてなにか資料等があれば教えてください。
また、新規インストールするしかない場合、データ移行手順についても資料等
があればよろしくお願いします。


 
プロフィール メール
引用して書き込む
fuyuki
 2011年11月17日 00:09 JST  
掲示板

状態: オフライン
登録日: 2007年8月25日
投稿数: 14

CEAS-Sakai 1.0.3には2つのバージョンが存在します。
(マイナーチェンジだったのでバージョンは同じです。)
この間にDBの変更が生じていますので、どちらのバージョンを
ダウンロードしたかで対応が変わります。

①CEAS-Sakai 1.0.3 [20110201]を現在お使いの場合
warを一度展開していただいてプログラムの入替えを行ってください。

②CEAS-Sakai 1.0.3 [20100924] を現在お使いの場合
基本的には①と同じですが、DBの変更を行って頂く必要があります。
展開したwarの中にDBの変更用のSQL(DBchange201010.sql)を用意しております。

こちらは1.0.4にも含めていたのを確認致しましたので
(pache-tomcat-6.0.18/webapps/Core1/WEB-INFにあります)、
こちらを実施してDBを変更してください。


 
プロフィール メール
引用して書き込む
内容生成: 0.19 秒
トピック新規登録 新しく書き込む


通常 通常
ロック済 ロック済
注目トピック 注目トピック
新着 新着
注目トピック新着 注目トピック新着
ロック済トピック 新着 ロック済トピック 新着
ゲストユーザの投稿を見る 
ゲストユーザ投稿可能 
一部のHTMLを許可